Problem WordPress – Gepostet am %A %B %e%q, %Y – qtranslate

Weil es so schön ist, kommt hier gleich die nächste Lösung für ein kleines aber nerviges WordPress Problem. Genauer gesagt ein Problem im WordPress in Verbindung mit Qtranslate. qtranslate war ja bereits schon einmal Thema hier (Problem qtranslate WordPress 3.6 – gelöst).

Nach dem letzten Update (Versuch) von qtranslate ist mir aufgefallen, dass unter meinen (Blog-) Beiträgen kein Datum steht sondern das etwas kryptischere %A %B %e%q, %Y – oder so ähnlich. Woran liegt das?

Nach kurzer Recherche ist mir aufgefallen, dass es sich hierbei um einen Fehler in qtranslate handelt. Lustiger weise gibt es diesen Fehler auch in der aktuellsten Version von qtranslate mit der Versionsnummer 2.5.35.

Die Lösung für das Problem

ist relativ einfach, wenn man weiss wo man suchen soll/muss. Hier die Schritt für Schritt Anleitung:

  • Logt euch in euer Admin-Dashboard ein
  • wählt auf der linken Seite den Punkt “Plugins” aus
  •  sucht euch den Eintrag für qtranslate
  • hier klickt ihr auf bearbeiten (Unter dem Titel des Plugins)
  • Es öffnet sich der WordPress-eigene Editor (hier könnt ihr die Files direkt online bearbeiten)
  • Auf der rechten Seite wählt ihr nun die Datei qtranslate_utils.php
  • mit Strg+F nach dem folgenden Begriff suchen (ca. Zeile 144)
    $strftime_parameters[] = '%%';
  • Nun löscht ihr eines der beiden % Zeichen
  • Klickt auf Datei aktualisieren
  • Fertig

Das Datum an dem euer Beitrag gepostet wurde sollte nun wieder richtig angezeigt werden.

Einfach oder?




Der Artikel hat euch gefallen? Ihr wollt keinen neuen Artikel mehr verpassen? Liked meine Facebook-Seite und ihr verpasst keinen Artikel mehr und es gibt jede Menge zusätzlicher Infos und Videos, die es nicht auf diese Seite schaffen aber auch verdammt lustig sind. Oder ihr abonniert den RSS Feed!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.